Discoverflow | Anguilla | FAQ | notifications

Your 3G phone and other 3G devices will no longer work on the major mobile carriers in the USA as a result of the decommissioning of their 3G technology which will be phased out across the networks during 2022. This will be effective as at the following dates:

NetworkTermination Date
AT & TFebruary 22, 2022
T-MobileJuly 1, 2022

Yes. All prepaid and postpaid services on 3G devices in the US will be impacted – voice, data and SMS.

Yes. If you have 4G LTE or 5G devices you will still be able to use your device to access data roaming services in the 4G LTE or 5G network coverage areas. This means that customers will still be able to use their mobile apps to make calls, send texts, check emails, browse and watch content.

In order to access traditional voice roaming on 4G LTE or 5G networks , you will need to have a VoLTE (Voice over LTE) capable 4G LTE or 5G device. This is the functionality that makes it possible for voice quality calls to be made over the LTE/4G mobile network. This feature will need to be activated on the device in order for you to be able to make these calls.

At this time, we are in the process of improving our network to implement the VoLTE capability to facilitate traditional voice calling while in the USA. We will update our website as soon as it is available.

Most recent 4G/LTE SIM cards will work with VoLTE. To check if you have an LTE SIM, dial *555# and the SIM status will be displayed on your phone. However, if you are unsure, please call our contact centre and speak with a representative by dialing 100 for consumer or 1-800-744-0222 for business.

  • Upgrade your device from 3G to a 4G LTE or 5G one that supports VoLTE
  • Upgrade your SIM card to an LTE SIM
  • Ensure that you subscribe to a suitable roaming package before departing
  • When the VoLTE functionality is available on our network:
    • Ensure that VoLTE feature in your device is activated and updated with the latest version
    • Ensure that VoLTE is switched on prior to travelling

SAMSUNG
Model NameModel CodeVolteVoWifi
Galaxy S22 UltraSM-S908EYesYes
Galaxy S22+SM-S906EYesYes
Galaxy S22SM-S901EYesYes
Galaxy A13SM-A135MYesYes
Galaxy A23SM-A235MYesYes
Galaxy A03 CoreSM-A032MYesYes
A02SM-A022MYesYes
A02sSM-A025MYesYes
A10SM-A105MYesYes
A10sSM-A107MYesYes
A11SM-A115MYesYes
A12SM-A125MYesYes
A12SM-A127MYesYes
A20sSM-A207MYesYes
A21sSM-A217MYesYes
SAMSUNG
Model NameModel CodeVolteVoWifi
A22SM-A225MYesYes
A31SM-A315GYesYes
A32SM-A325MYesYes
A50SM-A505GYesYes
A51SM-A515FYesYes
A52SM-A525GYesYes
S20 FESM-G780FYesYes
S9SM-G9600YesYes
S9+SM-G9650YesYes
S10SM-G973FYesYes
S20+SM-G985FYesYes
S21SM-G991BYesYes
S21+SM-G996BYesYes
NOTE 20SM-N980FYesYes
NOTE 20 ULTRASM-N985FYesYes
iPhone 12

Apple

Apple computer support IMS, to enable VoLTE Roaming you must have iOS 15

Previous version support VoLTE from iPhone 7 onwards

Android

Other Android

They require SW adaptation to supportVoLTE and VoLTE Romaing

Adaptation are being worked on withAlcatel, ZTE, etc